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Overview 

i>clicker 5.4 provides you the convenience of downloading a class roster from WebCT 

Vista rather than creating a roster from scratch. We recommend this option if you use 
WebCT Vista to post your course grades.  

This guide will walk you through the steps for registering i>clicker remotes using your 

WebCT Vista course roster and then exporting your polling results for use with the WebCT 
Vista gradebook. 

Using your WebCT Vista roster to register clickers 

Creating a Course and Setting Preferences in i>clicker 

 

1 Open your iclicker Win or i>clicker Mac folder and double-click the i>clicker icon. 

2 The Welcome to i>clicker window opens with no courses listed. Click Add Course. 

 

3 An Add Course window appears. Enter your Course Name, Course Number, and Section Number. 

This combined information will serve as the unique identifier for your course. 

 

NOTE: It is no longer necessary to make a separate copy of the MyCoursePC or 
MyCourseMac folder for each i>clicker course or section. A single copy of the new 

iclicker Win folder now gives you access to all your courses and sections.  
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4 Click Create. i>clicker automatically creates a new course folder in your iclicker 

Win\Classes or i>clicker Mac:Classes folder. The Add Course window closes and you are 
returned to the Welcome screen where you will see your course name in the list of 

courses. 

5 Select your course from the course list and click Choose. 

 

6 The Main Menu screen will appear. Click the Your Settings and Preferences link. 

 

7 Locate the Registration/Export tab. Under Course Management System select Vista 
(formerly WebCT Vista). Click Set for Course. 
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NOTE: Unless your institution is hosting registration on campus/locally, the Security 
Code for Web Synchronization should either be blank, contain “SQL” in the field.  

 

WARNING: When you modify the i>clicker Settings and Preferences as described 
above, you will receive an alert like the one below. This alert is simply a reminder 
that you need to add your WebCT Vista roster before trying to export i>clicker data 
for use in your WebCT Vista course. Adding your roster is covered in the next steps. 

 

Exporting Your WebCT Vista Course Roster 

1 Log into WebCT Vista and select the course for which you are using i>clicker from the 
Course List.  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

NOTE: The appearance of your login screen will vary depending on the customizations 
made to the Vista Learning system at your campus. A browser check/browser tune up 
may begin automatically to ensure that Vista works properly with your browser.  



 

Using i>clicker with WebCT Vista  Instructor’s Guide 6 

 

2 Make sure you are on the Teach tab at the top of the screen. Under Instructor Tools, click 

on the Grade Book link. 

 

3 From the Grade Book, locate and select the Export to Spreadsheet option. On the 

resulting page, you will be prompted to answer a series of questions regarding your 
exported data. Answer these questions as shown in Step 4 below. 
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4 From the Export to Spreadsheet page, make sure you have selected the following choices 

and click Export: 

 Members to Export: All Members 

 Columns to Export: All Columns 

 Export Format: Comma-delimited 

 Character Set: Unicode (UTF-8) 

 

TIP: The options you see in the Export to Spreadsheet screen may vary depending on 
your campus’s Vista installation and the settings created by your WebCT/Blackboard 
administrator. If any of the choices described in Step 4 are not available to you, please 
contact i>clicker technical support for help downloading and modifying the Grade 
Book file to work with i>clicker. 

 

5 Save the file into your course folder within your iclicker Win or i>clicker Mac folder (e.g., 
iclicker Win\Classes\Sample Cal State Course or i>clicker Mac:Classes:Sample Cal State 

Course). 

 

NOTE: If you do not see your course folder in the iclicker Win\Classes or i>clicker 
Mac:Classes folder, complete steps 1-4 under Creating a Course and Setting 
Preferences in i>clicker. 
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6 Locate and open your course folder within the Classes folder. (e.g., iclicker 

Win\Classes\Sample Cal State Course or i>clicker Mac:Classes:Sample Cal State Course).  

 

7 Rename the file exportedcourse.csv to Class.txt. 

 

IMPORTANT: If the file appears to you as exportedcourse instead of 
exportedcourse.csv, you will need to perform the following steps:  

For Win (PC):  

1. Open My Computer.  

2. From the menus at the top, go to Tools > Folder Options. 

3. Click the View tab. In the list of Advanced Settings on the View screen, 

scroll down to Hide extensions for known file types and uncheck this box. 
Click Apply, then OK.  

4. Close the My Computer window.  

For Mac:  

1. Click anywhere on the Desktop, then from the top of the screen go to 

Finder > Preferences.  

2. Click the Advanced tab.  

3. Check the Show all Extensions box, then close the Preferences window.  

 
 

TIP: We recommend that you open the CSV file to make sure that file includes 
student last name, student first name, and student WebCT Vista ID.  
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Registering i>clicker Remotes Using Web Registration 

Online registration is recommended, especially for classes of fifty students or more. To 
register online, send your students to www.iclicker.com and ask them to locate the 

Register Your i>clicker button. For complete instructions, see Web Registration (Option 1) 
in the i>clicker 5.4 Quick Start Guide available at www.iclicker.com. 

After your students have registered online, you need to synchronize i>grader to update 

the information in your class folder. (See Synchronizing Web Registrations below.) 

Registering i>clicker Remotes Using Roll Call Registration 

The roll call registration option is ideal for small classes (fifty or fewer students) and can 

be used with your WebCT Vista  course roster. To use the roll call registration option, 
follow the steps outlined under Roll Call Registration (Option 2) in the i>clicker 5.4 Quick 

Start Guide available at www.iclicker.com. 

When using roll call registration, the students’ last names, first initials, and Blackboard 
user IDs scroll across the screen. Students locate their names and click a key combination 

on their i>clicker remotes to assign their remotes to their names in the course roster. 

Synchronizing Web Registrations 

NOTE: Before you can use the Web Synchronization feature in i>grader, you must 
run at least one i>clicker session with your students, and your students need to 
register their i>clicker remotes online as described in Step 1 below. 

 

To synchronize web registrations with your WebCT Vista roster: 

1 Students will need to visit http://www.iclicker.com/registration/index.html and complete 

the registration form. The students should enter their WebCT Vista usernames as the 
Student ID. 

TIP: You may want to add registration ID instructions to your syllabus. We have 
provided First Day of Class materials (PowerPoint slides, syllabus attachment, web 

flyer) that you can customize and use for these purposes. You can find those 
under the Support > User Guides section of www.iclicker.com. 

 

http://www.iclicker.com/
http://www.iclicker.com/
http://www.iclicker.com/
http://www.iclicker.com/registration/index.html
http://www.iclicker.com/


 

Using i>clicker with WebCT Vista  Instructor’s Guide 10 

 

2 Double-click the i>grader icon, select your course, and click Open i>grader. You will see 

your session(s), labeled by date, and you will see remote IDs in red on the left. 

 

TIP: If you do not see a column of remote IDs in red on the left, you may not have 
run a polling session with your students yet. Please run a session in i>clicker before 
attempting the Web Synchronization function. 

 

TIP: Check to be sure WebCT Vista is your listed CMS on the lower left corner of the 
screen (Output formatted for: WebCT Vista). Your choice of WebCT Vista as your 

course management system was carried over from your Settings and Preferences 
selection in i>clicker. 

 

3 Click the Synchronize Student Web Registrations button. 

The Web Synchronization function will take the remote IDs from the session you 

conducted with your students, and look for them via a database server. It will match the 
i>clicker remotes used in your class to the user IDs your students registered with on the 

web site.  

The student user IDs are then checked against the usernames found in the exported file 
from the WebCT Vista Grade Book. If your students did not register using their WebCT 

Vista usernames, you will be prompted to accept or ignore the registration. We 
recommend jotting down that user’s information and choosing ignore.  Then ask the 

student to register again using the correct information.  

TIP: If you find that many of your students entered the wrong user ID when 
registration on the iclicker.com website, prompt them to uniformly re-register with 
their WebCT Vista User ID. 
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Uploading grades from i>grader into WebCT Vista 

1 When you are ready to upload your i>clicker polling data into WebCT Vista, open 
i>grader. Make sure Output formatted for lists WebCT Vista and above (see screen shot 

below).  

 

 

 

 

 

 

 

 

 

 

 

 

2 To export data from one or multiple sessions, check the box at the top of each column 
you want to export (next to the session name or session date). After you’ve selected your 

desired session(s), click Export Selected Sessions as csv file from the main i>grader 
screen. To export scores for the whole term, click Export All Sessions. The scores will be 

saved in your course folder in a file called Uploadfile.csv (e.g., iclicker 
Win\Classes\Sample Cal State Course\Uploadfile.csv or i>clicker Mac:Classes:Sample 

Cal State Course:Uploadfile.csv.) 

 

NOTE: Only one Uploadfile.csv can exist in your course folder at once. If you wish 
to export data into more than one file during a single i>grader session, you will 
need to move or rename the previously created Uploadfile.csv before exporting a 
different selection of sessions. When you no longer need the information in the 
exported file, you may leave it in your course folder and it will simply be 
overwritten the next time you need to export. 

 

3 Log into WebCT Vista (and into your course) and go back to Grade Book (Teach > 

Instructor Tools > Grade Book). 
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4 Locate and select the Import from Spreadsheet option. 

 

5 From the Import File page, click Browse and select the Uploadfile.csv from your course 

folder (e.g., iclicker Win\Classes\Sample Cal State Course\Uploadfile.csv or i>clicker 
Mac:Classes:Sample Cal State Course:Uploadfile.csv.). Keep the settings Separator: 

Comma and Character Set: Unicode (UTF-8).  

 

6 Click Upload. 
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7 You will then be taken to a new Import File page, an example of which is shown below. 

The User ID column is required and must be set as noted in the screenshot. For all other 
rows of data, select Add as new column for any grades you wish to import, and Do not 

import for all other columns. For example, if you exported an entire term of i>clicker 
sessions but wanted to add only the total points (no individual sessions) to your Grade 

Book, you would select Add as new column for Total and Do not import for all other 
columns.  

 

TIP: The Match column on this Import File screen alerts you if there is already an entry 
in your Vista Grade Book with the same name as the column you are about to import. 
The User ID column is used to match the data in your file with the students in your 
Grade Book and should have a green check next to it. If you see a green check for any 
other row of data in the spreadsheet, make certain that you manually select the Add 
as new column option from the drop-down list, or you will over-write your existing 
grades. 

 

8 After selecting the above, click Import.  

9 You will see an Import Errors page listing any columns that you chose not to import, as 

well as any columns that were renamed to avoid duplicate column names. Click OK.  

10 Once the import process has completed, you will be taken to the main Grade Book 
screen. From here, you may view the data you’ve imported into your Vista course.  

 

Any questions? Feel free to contact us at support@iclicker.com. 
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