Download iClicker Classic

IMPORTANT: Your institution may be using a customized version of iClicker Classic. Click here to see if your institution is using a custom version. Otherwise, download the standard version below.

Minimum supported version: iClicker Classic 7.19. Requires Windows 7 with .NET 4.0.3 or newer, macOS High Sierra (10.13) or newer, or Linux Ubuntu LTS (12.04, 14.04, 16.04) 64-bit.

Mac users: View a short video that covers the two-step process for setting up iClicker Classic software to integrate with an LMS

Release Notes 7.27 (US)
Release Notes 7.6 (EMEA)
Release Notes 7.4 (AU)
User Guide

EMEA Latin America Asia Pacific

Australia / New Zealand

iClicker Classic Screenshot